Grids: Layout builder for WordPress

网名号推荐:专升本 养老院 网络推广

👉有关插件的更多信息,请访问文档网站。

布局构建器是一种工具,可帮助您在页面中创建视觉结构,从由相邻列构成的简单布局到更复杂的组合。Grids 完全基于 WordPress 块编辑器,这意味着您将能够将它与来自世界各地的开发人员和设计师正在创建的无数内容块一起使用。

借助 Grids,我们为使用 WordPress 块编辑器编写的内容带来了视觉结构。

👉部分和区域
部分是页面的一部分,旨在在视觉上与其他内容区分开来。部分通常是您一个接一个添加的顶级块;部分的顺序是什么使您的页面布局。

您创建的每个部分都由几个不同的区域组成。在它们最基本的形式中,您可以将区域视为列,它们只不过是内容块的容器。

对于更精细的合成,网格设计器允许您使用 CSS 网格在部分边界内精确创建所需的网格结构。

👉 想知道更多?阅读插件文档! 👉 https://justevolve.it/grids/documentation/

👉 还在苦苦挣扎?这可能取决于已知问题之一👉 https://justevolve.it/grids/documentation/known-issues/

😎 观看 Matt Mullenweg 在 WordCamp Europe 2019 上展示的 Grids!

👉1.3.8
FIX:修复了部分和区域的显示设置功能。
👉1.3.7
修复:修复了部分和区域背景的后备变量问题。
👉1.3.6
FIX:修复了不同媒体查询上的边距、填充关联的问题。
FIX:修复了前端的背景重复和位置默认行为。
👉1.3.4 & 1.3.5
修复:前端/后端上的同步行维度逻辑:空行也会在块编辑器屏幕上折叠。
👉1.3.3
FIX:修复了使用宽对齐部分时发生的 500 错误。
👉1.3.2
FIX:将网格列声明更改为 minmax(0,1fr) 以防止网格爆裂。
FIX:修复了嵌套部分的问题。
👉1.3.1
修复:恢复的行维度逻辑:在使用高级编辑器创建的部分中,空行将折叠。
👉1.3.0
增强功能:增加了与完整站点编辑器的兼容性。
增强:增强了与单页应用程序网站的兼容性。
FIX:固定样式应用于嵌套部分。
更新了与​​ WordPress 5.9 的兼容性。
可能的重大变化:

在此版本中,我们删除了允许在使用块编辑器编辑页面时使编辑器区域更宽的全局页面设置。我们认为这应该由主题本身更好地处理,特别是如果它支持完整站点编辑模式。
我们还删除了确定区域之间水平间距的全局页面设置。这现在由部分块单独处理(查找间隙设置)。和以前一样,水平和垂直间隙都受媒体查询的影响。
我们已经从它们各自的元素中删除了grids-s-$section_id和grids-a-$area_id类,因为不再需要它们来生成元素的样式。如果您需要专门识别一个部分或区域,您可以使用块编辑器提供的自定义类/锚控件。
👉1.2.28
增强功能:添加了通过网格/区域过滤器指定部分内容区域中允许的块类型的功能。
增强功能:添加了通过网格/通用过滤器指定网格中使用的大小单位以及编辑器建议的默认大小单位的功能。
修复:将不需要的日志删除到控制台。
更新了与​​ WordPress 5.7 的兼容性。
👉1.2.27
FIX:修复了编辑自定义创建的部分并影响先前创建的区域时发生的问题。
修复:修复了在使用具有自定义帖子类型的网格时阻止保存帖子元的问题。
👉1.2.26
FIX:增加了与 WordPress 5.6 和最新版本的 Gutenberg 插件的兼容性。
👉1.2.25
FIX:较小的后端 UI 修复。
FIX:修复了前端内容区域中块的尺寸。
👉1.2.24
增强了对 AJAX 驱动的内容页面的支持。
👉1.2.23
FIX:修复了当 SCRIPT_DEBUG 常量设置为 true 时发生的 React 警告和错误。
FIX:修复了预览模式下的部分样式。
FIX:拖动区域时删除了双滚动条。
👉1.2.22
修复:增加了与 WordPress 5.4 的兼容性。
👉1.2.21
FIX:修复了导致部分 ID 不在页面标记中呈现的错误。
👉1.2.20
FIX:修复了与 Gutenberg 7.3 的兼容性。
👉1.2.19
FIX:固定块工具栏问题。
👉1.2.18
修复:修复了部分的可重用块功能。
FIX:各种小的 UI 调整。
修复:小错误。
👉1.2.17
FIX:修复了与 Gutenberg 7.2 的兼容性。
FIX:轻微的 UI 调整。
👉1.2.16
修复:修复了 Internet Explorer 11 上的网格显示问题。感谢@amddtim提供修复。
👉1.2.15
改进了间距控件中单位的可视化。
添加了扩展编辑器宽度的选项。
👉1.2.14
修复:修复了与 WordPress 5.3 的兼容性。
👉1.2.13
FIX:修复了区域选择突出显示的 z-index 问题。
修复:修复了阻止正确显示重复部分的问题。
👉1.2.12
FIX:改进了高级网格中两个垂直相邻区域中块的编辑。
FIX:修复了块预览中的区域宽度显示问题。
👉1.2.11
使用维度控件时向元素添加了视觉反馈。
修复:修复了阻止在区域中正确使用垂直对齐的回归。
👉1.2.10
修复:修复了在指定锚点时阻止部分正确保存的错误。
FIX:轻微的 UI 调整。
👉1.2.9
为 Sections 添加了锚点支持:您现在可以在前端的 Section 元素中添加 ID。
各种 UI 调整以突出显示网格结构和渲染。
从网格部分中删除了部分块,并在布局块部分中可用。
更改了部分和区域块图标以匹配插件品牌。
修复:在页面中插入部分后的第一个块选择。
修复:小错误。
👉1.2.8
FIX:在块编辑器中复制部分时区域的样式对齐。
👉1.2.7
FIX:使用 Gutenberg 插件时为新创建的区域恢复块插入模式。
FIX:与 Gutenberg 5.9.0 的兼容性修复。
👉1.2.6
修复:添加横向间距时内容区域的行为。
👉1.2.5
为具有“宽”对齐的部分的背景添加了一个新的“拉伸”选项。
修复:小错误。
👉1.2.4
将网格提交到 WordPress.org 上的 Blocks 目录。
包括 JS 和 SCSS 源文件。
👉1.2.3
z-index修复:修复了在调整区域的时阻止正确显示块插入器的问题。
FIX:修复了一个问题,该问题可能导致多个区域被添加到一个部分,而不使用网格设计器组件。
FIX:小错误修复。
👉1.2.2
修复:修复了阻止自定义强调色在二十九默认主题上按预期工作的问题。
👉1.2.1
FIX:轻微的视觉调整。
FIX:编辑使用网格设计器组成的部分。
👉1.2
新功能:添加了页面范围的装订线控制。
增强功能:现在可以在编辑部分时使用网格设计器,并且可以重新排列区域。
修复:未在循环中显示的网格的 CSS 样式。
FIX:部分现在可以用作可重复使用的块。
修复:小错误。
👉1.1.1
修复:翻译支持。
修复:块工具栏问题。
👉1.1.0
新功能:网格设计器。
修复:翻译支持。
修复:小错误。
👉1.0.0
首次公开发布。

下一篇: